Problems using credentials generated in IBM API Connect

Symptoms

If you have an integration set up with API Connect, and you are using credentials generated by API Connect, clients will no longer be able to authenticate and consume Kafka topics through the Event Gateway after you upgrade to Event Endpoint Management 11.0.4.

Credentials generated within the Event Endpoint Management Catalog will continue to work.

Kafka client logs will contain the following errors if they attempt to connect with a username and password generated in the API Connect Developer Portal and Event Endpoint Management 11.0.4:

[main] ERROR org.apache.kafka.clients.NetworkClient - [Consumer clientId=<clientId>, groupId=<groupId>] Connection to node -1 (<gateway address>) failed authentication due to: 
[main] WARN org.apache.kafka.clients.NetworkClient - [Consumer clientId=<clientId>, groupId=<groupId>] Bootstrap broker <gateway address> (id: -1 rack: null) disconnected
Exception occurred in application code:
org.apache.kafka.common.errors.SaslAuthenticationException: 

Causes

A code issue was introduced in Event Endpoint Management version 11.0.4 where credentials generated in API Connect would not be correctly passed on to the Event Gateway. As a result, generated credentials are not accepted by the Event Gateway when presented by a connecting client.

Resolving the problem

To resolve the problem, update your Event Endpoint Management instance to version 11.0.5.