Symptoms
A virtual topic does not appear in IBM API Connect Developer Portal after it has been published.
Causes
This issue can occur due to several reasons:
- The integration between Event Endpoint Management and Developer Portal is not configured correctly.
- The wrong publishing destination was selected during the publish process.
- Errors occurred during the publishing process.
Resolving the problem
To resolve this issue, complete the following steps:
- Verify that the integration between Event Endpoint Management and Developer Portal is configured correctly.
- Check that you selected Developer Portal or Both as the publishing destination when you published the virtual topic.
- Check the Event Endpoint Management logs for any errors during the publishing process.
- Check the Developer Portal logs for any errors during the publishing process.